Verified Commit 5b52812e authored by Huste, Tobias (FWCC) - 111645's avatar Huste, Tobias (FWCC) - 111645
Browse files

tests: fix hanging doc building tests

sphinx-contrib-versioning seems to be not yet compatible with
Sphinx>2.0. Pin Sphinx as long as build of documentation keeps hanging.
parent 90993ec1
Pipeline #13561 failed with stages
in 21 minutes and 52 seconds
......@@ -241,7 +241,7 @@ py3.6-pypi-mysql:
- pip install coveralls requirements-builder
- requirements-builder -e $EXTRAS --level=$REQUIREMENTS setup.py > .ci-$REQUIREMENTS-requirements.txt
- pip install -r .ci-$REQUIREMENTS-requirements.txt
- pip install -U git+https://github.com/leokoppel/sphinxcontrib-versioning.git#egg=sphinxcontrib-versioning
- pip install -U git+https://github.com/sphinxcontrib-versioning-ng/sphinxcontrib-versioning.git#egg=sphinxcontrib-versioning
- pip install -e .[$EXTRAS]
test-docs:
......
......@@ -47,7 +47,8 @@ tests_require = [
extras_require = {
'docs': [
'Sphinx>=1.5.6',
'Sphinx>=1.5.6,<2.0', # FIXME: Remove pinning when
# sphinx-contrib-versioning is compatible.
'sphinx_rtd_theme>=0.2.4',
],
'mysql': [
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment