Verified Commit 056acfcf authored by Huste, Tobias (FWCC) - 111645's avatar Huste, Tobias (FWCC) - 111645
Browse files

depdendencies: fix dependency issues with oauthlib

parent 7d2bf27b
Pipeline #9683 passed with stages
in 17 minutes and 53 seconds
......@@ -75,6 +75,7 @@ setup_requires = [
install_requires = [
'celery>=4.0.2',
'Flask-OAuthlib>=0.9.3',
'humanize>=0.5.1',
'invenio-accounts>=1.0.0',
'invenio-admin>=1.0.0',
......@@ -85,9 +86,11 @@ install_requires = [
'invenio-records-files>=1.0.0a10',
'invenio-rest>=1.0.0',
'invenio-cache>=1.0.0',
'oauthlib>=1.1.2,!=2.0.0,!=2.0.3,!=2.0.4,!=2.0.5,<3.0.0',
'paramiko>=2.3.2',
'pexpect>=4.0.1',
'redis>=2.10.5',
'requests-oauthlib>=0.5.0,<1.2.0',
# "requests" has hard version range dependency on "idna" and "urllib3"
# Every time "idna" and "urllib3" are updated, installation breaks because
# "requests" dependencies are not resolved properly.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment