Commit a6058f51 authored by femiadeyemi's avatar femiadeyemi
Browse files

Update dependency-check-suppressions.xml

parent b1f20a97
Pipeline #45359 failed with stages
in 10 minutes and 27 seconds
<?xml version="1.0" encoding="UTF-8"?>
<suppressions xmlns="https://jeremylong.github.io/DependencyCheck/dependency-suppression.1.3.xsd">
<suppress until="2020-09-30Z">
<suppress>
<notes><![CDATA[
file name: spring-security-core-5.3.2.RELEASE.jar
]]></notes>
<sha1>83fed9c3ee4a014b6a6cacfc7042eb325dca6766</sha1>
<cpe>cpe:/a:pivotal_software:spring_security</cpe>
</suppress>
<suppress until="2020-09-30Z">
<suppress>
<notes><![CDATA[
file name: spring-security-oauth2-core-5.3.2.RELEASE.jar
]]></notes>
......@@ -16,7 +16,7 @@
<cpe>cpe:/a:pivotal_software:spring_security</cpe>
<cpe>cpe:/a:pivotal_software:spring_security_oauth</cpe>
</suppress>
<suppress until="2020-09-30Z">
<suppress>
<notes><![CDATA[
file name: tomcat-embed-core-9.0.35.jar
]]></notes>
......@@ -25,7 +25,7 @@
<cpe>cpe:/a:apache_software_foundation:tomcat</cpe>
<cpe>cpe:/a:apache_tomcat:apache_tomcat</cpe>
</suppress>
<suppress until="2020-09-30Z">
<suppress>
<notes><![CDATA[
file name: spring-security-oauth2-jose-5.3.2.RELEASE.jar
]]></notes>
......@@ -34,14 +34,14 @@
<cpe>cpe:/a:pivotal_software:spring_security</cpe>
<cpe>cpe:/a:pivotal_software:spring_security_oauth</cpe>
</suppress>
<suppress until="2020-09-30Z">
<suppress>
<notes><![CDATA[
file name: spring-security-web-5.3.2.RELEASE.jar
]]></notes>
<sha1>c2459ad6f4c56754d4938a71ffd2426dea46d4e1</sha1>
<cpe>cpe:/a:pivotal_software:spring_security</cpe>
</suppress>
<suppress until="2020-09-30Z">
<suppress>
<notes><![CDATA[
file name: tomcat-embed-websocket-9.0.35.jar
]]></notes>
......@@ -50,14 +50,14 @@
<cpe>cpe:/a:apache_software_foundation:tomcat</cpe>
<cpe>cpe:/a:apache_tomcat:apache_tomcat</cpe>
</suppress>
<suppress until="2020-09-30Z">
<suppress>
<notes><![CDATA[
file name: spring-security-config-5.3.2.RELEASE.jar
]]></notes>
<sha1>88b84564a3db5c39e2a8c171520022d2d1a67607</sha1>
<cpe>cpe:/a:pivotal_software:spring_security</cpe>
</suppress>
<suppress until="2020-09-30Z">
<suppress>
<notes><![CDATA[
file name: spring-security-oauth2-client-5.3.2.RELEASE.jar
]]></notes>
......@@ -66,4 +66,200 @@
<cpe>cpe:/a:pivotal_software:spring_security</cpe>
<cpe>cpe:/a:pivotal_software:spring_security_oauth</cpe>
</suppress>
</suppressions>
\ No newline at end of file
<suppress>
<notes><![CDATA[
file name: jakarta.websocket-api-1.1.2.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/jakarta\.websocket/jakarta\.websocket\-api@.*$</packageUrl>
<cve>CVE-2020-11050</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: javax-websocket-server-impl-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty\.websocket/javax\-websocket\-server\-impl@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: jetty-server-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty/jetty\-server@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: spring-core-5.2.6.RELEASE.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.springframework/spring\-core@.*$</packageUrl>
<cve>CVE-2020-5421</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: websocket-server-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty\.websocket/websocket\-server@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: javax-websocket-client-impl-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty\.websocket/javax\-websocket\-client\-impl@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: jetty-xml-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty/jetty\-xml@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: spring-aop-5.2.6.RELEASE.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.springframework/spring\-aop@.*$</packageUrl>
<cve>CVE-2020-5421</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: websocket-common-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty\.websocket/websocket\-common@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: jetty-http-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty/jetty\-http@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: spring-web-5.2.6.RELEASE.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.springframework/spring\-web@.*$</packageUrl>
<cve>CVE-2020-5421</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: websocket-client-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty\.websocket/websocket\-client@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: jetty-util-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty/jetty\-util@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: spring-jcl-5.2.6.RELEASE.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.springframework/spring\-jcl@.*$</packageUrl>
<cve>CVE-2020-5421</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: websocket-servlet-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty\.websocket/websocket\-servlet@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: jetty-plus-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty/jetty\-plus@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: spring-beans-5.2.6.RELEASE.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.springframework/spring\-beans@.*$</packageUrl>
<cve>CVE-2020-5421</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: jetty-jndi-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty/jetty\-jndi@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: spring-webmvc-5.2.6.RELEASE.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.springframework/spring\-webmvc@.*$</packageUrl>
<cve>CVE-2020-5421</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: jetty-webapp-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty/jetty\-webapp@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: spring-context-5.2.6.RELEASE.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.springframework/spring\-context@.*$</packageUrl>
<cve>CVE-2020-5421</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: jetty-client-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty/jetty\-client@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: spring-expression-5.2.6.RELEASE.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.springframework/spring\-expression@.*$</packageUrl>
<cve>CVE-2020-5421</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: jetty-servlet-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty/jetty\-servlet@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: jetty-servlets-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty/jetty\-servlets@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: jetty-security-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty/jetty\-security@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: jetty-annotations-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty/jetty\-annotations@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
<suppress>
<notes><![CDATA[
file name: jetty-continuation-9.4.28.v20200408.jar
]]></notes>
<packageUrl regex="true">^pkg:maven/org\.eclipse\.jetty/jetty\-continuation@.*$</packageUrl>
<cve>CVE-2019-17638</cve>
</suppress>
</suppressions>
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment