add explicit keras requirement

other wise version mismatch leading to https://github.com/yigbt/deepFPlearn/pull/11#issuecomment-1113750598
2 jobs for v1.5.0 in 12 minutes and 13 seconds (queued for 1 second)