Commit 01e46f14 authored by Matthias Bernt's avatar Matthias Bernt
Browse files

sync requirements

parent d621a5ae
FROM tensorflow/tensorflow:2.7.1-gpu
FROM tensorflow/tensorflow:2.6.0-gpu
# copy dfpl sources for installation
# unfortunatelly COPY setup.py README.md dfpl/ /deepFPlearn/
......
......@@ -3,15 +3,17 @@ channels:
- conda-forge
- defaults
dependencies:
# dev requirements
- conda-build=3.21.8
- conda=4.12.0
- jsonpickle=2.1.0
- pip=22.0.4
- pytest=7.1.1
# application requirements
- jsonpickle=2.1
- matplotlib=3.5.1
- numpy=1.19.5
- pandas=1.4.2
- pip=22.0.4
- pytest=7.1.1
- rdkit=2022.03.1
- scikit-learn=1.0.2
- tensorflow-gpu=2.6.0
- wandb=0.12.11
\ No newline at end of file
- wandb=0.12
\ No newline at end of file
jsonpickle==1.4.1
pandas==1.0.5
rdkit-pypi==2020.9.5.2
tensorflow==2.2.0
scikit-learn==0.23.1
matplotlib==3.2.2
numpy==1.20
scipy==1.4.1
h5py==2.10
\ No newline at end of file
pip==22.0.4
pytest==7.1.1
-e .
\ No newline at end of file
......@@ -18,13 +18,14 @@ setup(
],
python_requires='>=3.6',
install_requires=[
"jsonpickle",
"pandas",
"rdkit-pypi",
"keras",
"tensorflow",
"scikit-learn",
"matplotlib",
"jsonpickle~=2.1",
"matplotlib==3.5.1",
"numpy==1.19.5",
"pandas==1.4.2",
"rdkit-pypi==2022.03.1",
"scikit-learn==1.0.2",
"tensorflow=2.6.0",
"wandb~=0.12",
],
entry_points={
'console_scripts': ['dfpl=dfpl.__main__:main']
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment